iOS 16.4 Support For Web Push Notifications

Yep! Apple finally enabled the same type of push notifications in iOS 16.4 that Android has supported in Progressive Web Apps for literally years!

Now, this is not as easy to enable in iOS as it is on Android because Apple intentionally made it difficult to enable to protect users from spam notifications

Here’s how to do this on iOS if you would prefer to not use the iOS DiscourseHub app.

  1. In Safari browse to the
  2. You may see a banner asking to enable live notifications. Click to enable them if it does as due to a minor bug the rest of these steps will not work properly if you are asked and choose not to at this point. Theee is a fix though I have included below.
  3. Click the share icon
  4. Click Add to Home Screen*. This step is critical as The push notifications will not work if you don’t pin it to the Home Screen.
  5. Set the name. This will be shown as part of the notification and will appear in the Settings app in the Notifications section where you can control them like normal app notifications.
  6. Open the Home Screen bookmark and login to your account.
  7. You will see a banner promoting you to enable the notifications (yes, same as the one you may have got in step 2). You need to click to enable them here as well even if you got promoted in Safari back in step 2 and told it to enable them then. iOS treats Home Screen bookmarks as isolated apps.
  8. You should see a notification saying they were enabled.

That’s it, you should now get push notifications for any topic you are watching, PMs, and (if you have them enabled) chat.

Note: if you get the bug I mentioned in step two, here is the fix:

In your notification preferences in the Home Screen bookmark you need to do this and in this exact order:

  1. In the Home Screen bookmark go to the notifications prefs link above and click Disable Notifications and then Save Changes.
  2. Completely close Safari and the bookmark app from your app switcher.
  3. Open Safari and come back to the forums. If prompted, enable the notifications here (it sometimes fixes this part on its own)
  4. Go to your Home Screen and open the bookmark
  5. Go back to your notifications preferences and ignore the banner if it prompts you at this point to reenable the notifications.
  6. Click the Enable Notifications button and then Save Changes.

The notifications should now work correctly.

Oh, I should note a critical detail here.

The Discourse default setting to wait 10 minutes before sending the notifications has been modified to send the notifications after 1 minute instead. This was to make the chat notifications more useful :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.